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1 Introduction
The Hardware Service Pack (HSP) is an ETAS product for firmware management of 
ETAS hardware. It is a tool for adding new functionality to the hardware.

With HSP and connected ETAS hardware, users can 

- Check the current firmware state,

- Check the current firmware compatibility state,

- Update/downdate the firmware and

- Get the update activities logged

1.1 Release Notes
For new features of this HSP version, support of new products, and for information 
about firmware support use in the HSP program the menu options Help > Release 
Notes Service Package... and Help > Release Notes HSP-UT... 

1.2 Product Overview

1.2.1 Product Structure
The Hardware Service Pack is a tool for the firmware management of ETAS hard-
ware. HSP consists of two main parts:

- HSP Update Tool (HSP-UT) and

- HSP Service Packages (HSP-SP and LABCAR-FWP).

Fig. 1-1 Hardware Service Pack product structure

The HSP Update Tool (HSP-UT) is used for the firmware update process. This tool 
allows users to view the state of firmware in an ETAS hardware component. Based 
on this information, users can update the firmware. Please refer to the Release 
Notes for the current HSP-UT version for information about supported ETAS hard-
ware modules.

HSP

Hardware Service Pack

HSP-UT

HSP Update Tool

HSP-SP

HSP Service Packages

HSP-SP
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The HSP Service Packages (HSP-SP) contains the actual firmware, i. e., the files 
that will be downloaded to the hardware.

The version of the Hardware Service Pack (HSP) is changed if either the HSP 
Update Tool (HSP-UT) or if any of the HSP Service Packages (HSP-SP) was 
changed.

1.2.2 Product Feature
The main features of the HSP Update Tool are:

- Detailed information about firmware status for several systems available

- Detailed information about software application and firmware compatibility 

- After selection of product group firmware update in three steps only

- Free selection of the systems for firmware update among the displayed 
hardware

- User information by icons for easy readability of firmware status

• for the complete system
• for each updatable component in the system

- Icons change their status during the update process

- Up to 64 systems can be updated within the same update process

- Log files document the updates

- Program window layout is configurable

- Integrated online help
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1.3 User Information

1.3.1 User Profile
This manual is intended for qualified personnel working in the fields of automotive 
control unit development and calibration. 

1.3.2 HSP Online Help - Quick Guide 
Use the Help > Help menu option to invoke the general help function. Or press the 
<F1> function key to open context-sensitive help. 

Other entries: 

Help > HSP Getting Started Manual...

Help > Quick Start...

Help > Symbols...

Help > Technical Support...

Help > Supported Hardware...

Help > Open Source Software Attributions...

Help > Release Notes Service Package...

Help > Release Notes HSP-UT... 

Help > About... 
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2 Program Installation

2.1 Overview

2.1.1 Program Files and Windows User Rights

Main Installation File (HSP)
The HSP main installation file installs the Hardware Service Pack including the HSP-
UT and HSP-SP. 

Service Package Files (HSP-SP)
If a compatible HSP version is installed on your PC, there is the possibility to install 
additional HSP Service Packages (HSP-SP) with Windows standard user rights.

2.1.2 System Requirements 
Check the HSP Update Tool Release Notes for detailed information.

2.1.3 Restrictions

Using multiple masters
When updating the ETAS hardware with HSP, no other ETAS applications may 
access this hardware.

Windows User Rights
For restrictions because of Windows user rights, refer to chapter 2.1.1 on page 7.

2.1.4 Supported ETAS Products
Read the list of supported hardware at the HSP Online Help with Help > Supported 
Hardware...

NOTE
You need Windows administrator rights for installing the Hardware Service Pack 
HSP. 

NOTE
For installing the HSP Service Packages you need only Windows standard user 
rights. 

NOTE
For complete description of restrictions by using some hardware components, 
refer to the HSP Update Tool Release Notes. 
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2.2 Installation Procedure

2.2.1 Installing HSP Update Tool (HSP-UT) 

To start the HSP installation:
- Double click on the setup.exe file in the HSP installation package.

- Follow the instructions displayed by the installation wizard.

2.2.2 Installing HSP Service Packages (HSP-SP)
If a compatible HSP version is installed on your PC, it is possible to install additional 
Service Packages (HSP-SP) with Windows standard user rights.

The HSP Service Packages are available for all users of a PC, meaning all installed 
packages are available for selection in the HSP-UT regardless of user type.

The file format of all HSP Service Package files is *.spi.

There are three ways to select, import and install the HSP Service Packages:

- dobule click an HSP-SP file *.spi in Windows Explorer

or
- select in HSP program File > Import Service Package

or
- select in HSP program Tools > Service Package Manager >Import. 

NOTE
You need Windows administrator rights to install the Hardware Service Pack HSP. 

NOTE
The language selection made in the HSP installation is a global setting for all 
ETAS applications

NOTE
The complete procedure to install HSP Service Packages is described in the 
Online Help of HSP.
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2.3 LAN handling Support
The Hardware Service Pack supports the improved LAN handling of INCA with dif-
ferent configurations for hardware access by Ethernet: 

- Usage of different network adapters:

• one network adapter for the company LAN and
• one network adapter for the ETAS-hardware or

- Usage of one network adapter:

• automatic switch between company LAN and usage in automotive. 
To work with HSP it is necessary to configure the network environment of your PC 
for the ETAS hardware. The ETAS Network Manager supports your configuration.

To start ETAS Network Manager:
- In the HSP Main Window start menu select Tools > ETAS Network settings.

The ETAS Network Manager is started.

To select the network adapter used for the hardware:

- Select the network adapter used for the hardware from the Available 
Network Adapters field.

- Make the necessary settings in the Network Settings for ETAS hardware 
window.

- Click Finish.
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2.4 Uninstall Procedure

2.4.1 Uninstalling HSP Service Packages (HSP-SP) 

Using the HSP Service Package Manager as a part of HSP, all users can uninstall a 
selected HSP Service Package version (e.g. previous/older released service pack-
age) without uninstalling the HSP-UT.

To uninstall one or all HSP Service Packages:

- select in HSP program Tools > Service Package Manager

- select one or all packages

- select Uninstall Selected. 

2.4.2 Uninstalling HSP Update Tool (HSP-UT) 

This procedure describes how to uninstall the HSP Update Tool and all installed 
Service Packages.

To uninstall HSP: 
- Select in the Windows start menu Start Settings > Apps

- Select HSP Update Tool.

- Click Uninstall.

The Windows Installer window is displayed:

- Click Yes to start the HSP uninstallation. 

The uninstall process is started.

NOTE
For uninstalling of selected HSP Service Packages you only need Windows stan-
dard user rights. 

NOTE
Windows administrator rights are required to uninstall the HSP (HSP-UT with all 
HSP-SP files). 
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3 Using the HSP Update Tool
This section describes how to update the firmware on ETAS hardware. 

In this manual, the word ’update’ is used to describe the process of downloading a 
binary file, the actual firmware, from the PC to dedicated memory in ETAS hard-
ware. The downloaded firmware does not necessarily have to be a newer version 
than the firmware originally located on the hardware.

3.1 Starting the HSP Update Tool (HSP-UT)
The HSP-UT can be started either by double-clicking the HSP-UT icon on the desk-
top or from the Start menu under Programs > ETAS > HSP > HSP Update Tool. 
The HSP Update Tool window of the HSP-UT opens. In the following description, 
this window is named Main window.

When you select a particular version of the Hardware Service Pack, you are auto-
matically selecting the matching version of the Service Package, i. e., the actual 
firmware used by the HSP-UT.

Please refer to the HSP online help for details on menu options and button func-
tionality.

NOTE
Before starting the HSP-UT, please make sure that no ETAS Tool has access to 
the hardware. However, there will be an error message.
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3.2 HSP Update Tool Window
The HSP Update Tool window is also referred to Main window. 

1: Menu Bar

2: Toolbar

3: Hardware Window

4: Details Window

5: Properties Window

6: Compatibility Window

7: Output Window

8: Status Bar

3.3 Update Procedure
The sequence for updating the firmware is dependent on number of ETAS systems 
connected on the PC:

1. Connect the hardware to the PC and to power supply

2. Select the HSP version or the LABCAR-FWP version 

3. Click Search for hardware

4. Check the firmware state and select hardware systems whose firmware you 
want to update

5. Click Perform firmware update

NOTE
Neither the power supply nor the Ethernet connection may be interrupted 
during a firmware update!

1
2

3

4

5

6

7

8
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6. Additionally, you can check the current firmware state of one of the con-
nected hardware systems after a hardware search operation is finished.

3.4 Document the Firmware State 
The HSP Update Tool automatically creates two types of log files, the Firmware 
State Log File and the Firmware History Log File, which offer the possibility to 
document the firmware state and the firmware update activities. 

Contents of the log files can be viewed within HSP-UT window. As the files are in 
plain text format, they can simply be printed using text editors like Notepad.

3.4.1 Firmware State Log File
This feature makes it possible to document the current firmware state or a specific 
update sequence, i. e., the firmware state before and after the firmware update.

The Firmware State Log File will automatically be created the first time a search for 
hardware is performed after installing HSP. Afterwards this file will be overwritten 
with each hardware search. If a successful update follows a hardware search, the 
information will be appended to the file.

The content of the latest successfully executed update will remain when restart-
ing HSP. 

3.4.2 Firmware State History Log File
This feature makes it possible to browse the history on successfully executed 
firmware updates.

The Firmware State History Log File will also be automatically created the first time 
an update has been done after installation of HSP. It contains all previous versions 
of the firmware state log file. If a new firmware state log file is created, the content 
of this file is appended to the beginning of the history file.

If needed, the content of this file can be deleted. There is a maximum allowed size 
for this file. When the size reaches 500 kB the oldest update information will be 
truncated.

NOTE
Leaving HSP running may interfere with other ETAS applications.
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3.5 Driver Installation
HSP provides USB drivers for all devices that require their own USB drivers. 

It is recommended first to install the USB-drivers before connecting the hardware. 

The menu can be found at the main menu, Drivers

See example:
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4 Troubleshooting General Problems
This chapter provides information on solving problems that may arise, which are 
not specific to an individual software or hardware product.

The screenshots were taken from the English version of Windows 10, but the 
instructions should be similar for other windows systems.

4.1 Identifying the network adapter for the hardware
In the Windows search option, type in network and select following items: 

Check network status > Ethernet > Change adapter options

There might be several displayed adapters, and it might be difficult to decide, 
which one is used for the ETAS hardware. 

The next pictures from left to right display the Lenovo USB to Ethernet adapter 
named Ethernet 10 in following states. 

1. Removed from the USB-port

2. Inserted into the USB-port but no connection to the hardware

3. Inserted into the USB-port with connection to the hardware

Remove and reconnect the cable between ETAS hardware and the dedicated 
Ethernet connector. The changing symbol indicates the used network adapter. 

If no symbol changes: Check if the network card is recognized at all: 

If the network adapter can be unplugged like an USB to Ethernet-adapter, then 
unplug it form the USB-port and insert it again. The added icon will point to the 
adapter. It displays the network cable as unplugged. 

4.2 Ethernet adapter must be recognized and working
Check with the device manager and with the network connection, if the network 
card is recognized by the operation system and working. 

1) In the Windows search option, type device manager and open it. 
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2) In the Windows search option, type network and select following items: 

 Check network status > Ethernet > Change adapter options

In the following example, two USB to Ethernet adapters are used. 

- Lenovo with installed and working driver

- D-Link without driver installed and therefore not selectable

The first picture shows both network adapters removed. 

The next picture shows the Lenovo adapter under Network adapters. 

The D-Link adapter however is displayed under Other devices with a yellow sign. 

In the network connections, the Lenovo adapter is available, but the D-Link 
adapter is missing. Therefore, this D-Link adapter is not usable and requires an 
additional driver installation. 

4.3 Verifying the settings of the network adapter
Verify, that the identified adapter has the correct IP-address range settings at 
TCP/IP4.

example:

192.168.40.240 or 241 for the IP-Address and

255.255.255.0 for the Subnet mask.
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4.4 Verifying the ETAS Network settings 
Verify, that the identified Ethernet adapter is selected in the first row and that the 
IP-Address matches the properties of the network adapter. 

4.5 Ping the network card 
Make sure the network card is connected to the hardware. There should be no 
error message indicating disconnected hardware.

 In the Windows search option, type cmd and select the Command Prompt. 

type: 

ping 192.168.40.241 

It should display a Reply. 
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4.6 Ping the hardware device 
Make sure the network card is connected to the hardware. There should be no 
error message indicating disconnected hardware.

 In the Windows search option, type cmd and select the Command Prompt. 

Type ping and the IP-Address of the hardware e.g.:192.168.40.18, example: 

ping 192.168.40.18
It should display a Reply. 

If yes, the connection to the hardware is established. 

The HSP should be able to detect the ETAS-hardware: 

If HSP cannot detect the hardware, it is possible that

- The network manager is incorrectly configured or

- The firmware is corrupted and answers only with the basic function

- The hardware has a different IP-Address

4.7 APIPA is not displayed
APIPA is only displayed, after the correct Regedit settings. 

See: “Network Adapter cannot be selected via Network Manager” on page 19.
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4.7.1 Network Adapter cannot be selected via Network Manager

Cause: APIPA is disabled
The alternative mechanism for IP addressing (APIPA) is usually enabled. However, 
network security policies may request the APIPA mechanism to be disabled. In this 
case, you cannot use a network adapter which is configured for DHCP to access 
ETAS hardware. The ETAS Network Manager displays a warning message.

The APIPA mechanism can be enabled by editing the Windows registry. This is per-
mitted only to users who have administrator privileges. It should be done only in 
coordination with your network administrator.

To enable the APIPA mechanism:
- Open the Registry Editor:

- Click Search and type regedit and click OK.
The Registry Editor is displayed.

- Open the folder HKEY_LOCAL_MACHINE\SYSTEM\CurrentControl-
Set\Services\Tcpip\Parameters\

- Click Edit > Find to search for the key IPAutoconfigurationEnabled.

If you cannot find any instances of the registry key, the APIPA mechanism has not 
been disabled on your system, i. e., there is no need to enable it. Otherwise pro-
ceed with the following steps.

- Set the value of the key IPAutoconfigurationEnabled to 1 to enable 
the APIPA mechanism.

You may find several instances of this key in the Windows registry which 
either apply to the TCP/IP service in general or to a specific network adapter. 
You only need to change the value for the corresponding network adapter.

- Close the Registry Editor.

- Restart your PC to apply the changes.

4.7.2 Search for Ethernet Hardware fails

Cause: ETAS Hardware not responding
Occasionally the ETAS hardware might not respond. In this case switch off the 
hardware, then switch it on again to re-initialize it.

Cause: ETAS Hardware went into Sleep Mode
In order to save power, some ETAS devices will go into sleep mode if they do not 
see that they are connected to another device/computer.

To solve that, connect your Ethernet cable from your computer to the HOST/Sync 
In port on the device. After the device turns on, access the device using the web 
interface and adjust the settings to ensure it stays always on. Consult the 
device´s manual for specific instructions.
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Cause: ETAS Hardware is connected to another Logical Network
If you use multiple PCs or notebooks to access the same ETAS hardware, ensure 
that the network adapters are configured to use the same logical network. If this is 
not possible, power off and on the ETAS hardware between different sessions 
(repowering).

Cause: Device driver for network card not in operation
It is possible that the device driver of a network card is not running. In this case you 
will have to deactivate and then reactivate the network card.

Cause: Laptop power management deactivates the network card
The power management of a laptop computer can deactivate the network card. 
Therefore, you should turn off power monitoring on the laptop.

To switch off power monitoring on the laptop: 
- From the Windows Start Menu, select 

- Click Search and type Device Manager and click OK.
- In the Device Manager open the tree structure of the entry Network 

Adapters.

- Right click on the used network adapter and select Properties from the con-
text menu.

- Select the Power Management tab and deactivate the Allow the computer 
to turn off this device to save power option.

- Select the Advanced tab. If the property Autosense is included, deactivate 
it also.

- Click OK to apply the settings.
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5 Contact Information

Technical Support
For details of your local sales office as well as your local technical support team 
and product hotlines, take a look at the ETAS website:

 www.etas.com/en/hotlines.php

ETAS Headquarters
ETAS GmbH

Borsigstraße 24 Phone: +49 711 3423-0
70469 Stuttgart Fax: +49 711 3423-2106
Germany Internet: www.etas.com

https://www.etas.com/en/hotlines.php
https://www.etas.com


ETAS HSP V13 - Getting Started

22 | Index

Index

F
Feature

Product . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
Firmware Update Tool

Starting . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
H
HSP Online Help Quick Guide  . . . . . . . . . . 6
HSP Service Package . . . . . . . . . . . . . . . . . . 5
HSP Update Tool . . . . . . . . . . . . . . . . . . . . . . 11
I
Installation . . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
Installation Procedure . . . . . . . . . . . . . . . . . 8
Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . 4
L
Log File

Firmware State . . . . . . . . . . . . . . . . . . . .13
History State . . . . . . . . . . . . . . . . . . . . . .13

O
Overview

Product . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
P
Procedure, Update . . . . . . . . . . . . . . . . . . . 12
Product

Feature  . . . . . . . . . . . . . . . . . . . . . . . . . . . 5
Overview . . . . . . . . . . . . . . . . . . . . . . . . . . 4
Structure  . . . . . . . . . . . . . . . . . . . . . . . . . 4

Q
Quick Guide

HSP Online Help . . . . . . . . . . . . . . . . . . . 6
R
Release Notes  . . . . . . . . . . . . . . . . . . . . . . 4, 7
Restrictions . . . . . . . . . . . . . . . . . . . . . . . . . . . 7
S
Structure

Product . . . . . . . . . . . . . . . . . . . . . . . . . . . 4
Supported ETAS Products  . . . . . . . . . . . . 7
System Requirements  . . . . . . . . . . . . . . . . 7
U
Uninstall Procedure . . . . . . . . . . . . . . . . . . 10
Update . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11
Update Procedure  . . . . . . . . . . . . . . . . . . . 12
User Profile  . . . . . . . . . . . . . . . . . . . . . . . . . . . 6
W
Window

Main  . . . . . . . . . . . . . . . . . . . . . . . . . . 11, 12


	ETAS HSP V13
	1 Introduction
	1.1 Release Notes
	1.2 Product Overview
	1.2.1 Product Structure
	1.2.2 Product Feature

	1.3 User Information
	1.3.1 User Profile
	1.3.2 HSP Online Help - Quick Guide


	2 Program Installation
	2.1 Overview
	2.1.1 Program Files and Windows User Rights
	2.1.2 System Requirements
	2.1.3 Restrictions
	2.1.4 Supported ETAS Products

	2.2 Installation Procedure
	2.2.1 Installing HSP Update Tool (HSP-UT)
	2.2.2 Installing HSP Service Packages (HSP-SP)

	2.3 LAN handling Support
	2.4 Uninstall Procedure
	2.4.1 Uninstalling HSP Service Packages (HSP-SP)
	2.4.2 Uninstalling HSP Update Tool (HSP-UT)


	3 Using the HSP Update Tool
	3.1 Starting the HSP Update Tool (HSP-UT)
	3.2 HSP Update Tool Window
	3.3 Update Procedure
	3.4 Document the Firmware State
	3.4.1 Firmware State Log File
	3.4.2 Firmware State History Log File

	3.5 Driver Installation

	4 Troubleshooting General Problems
	4.1 Identifying the network adapter for the hardware
	4.2 Ethernet adapter must be recognized and working
	4.3 Verifying the settings of the network adapter
	4.4 Verifying the ETAS Network settings
	4.5 Ping the network card
	4.6 Ping the hardware device
	4.7 APIPA is not displayed
	4.7.1 Network Adapter cannot be selected via Network Manager
	4.7.2 Search for Ethernet Hardware fails


	5 Contact Information
	Index


