ETAS LABCAR-OPERATOR V5.4.13

Getting Started
Copyright

The data in this document may not be altered or amended without special notification from ETAS GmbH. ETAS GmbH undertakes no further obligation in relation to this document. The software described in it can only be used if the customer is in possession of a general license agreement or single license. Using and copying is only allowed in concurrence with the specifications stipulated in the contract.

Under no circumstances may any part of this document be copied, reproduced, transmitted, stored in a retrieval system or translated into another language without the express written permission of ETAS GmbH.

© Copyright 2022 ETAS GmbH, Stuttgart

The names and designations used in this document are trademarks or brands belonging to the respective owners.

LABCAR-OPERATOR V5.4.13 - Getting Started R01 EN -01.2022
# Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Subsection</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>About this Document</td>
<td>5</td>
</tr>
<tr>
<td>1.1</td>
<td>Classification of Safety Messages</td>
<td>5</td>
</tr>
<tr>
<td>1.2</td>
<td>Presentation of Instructions</td>
<td>6</td>
</tr>
<tr>
<td>1.3</td>
<td>Typographical Conventions</td>
<td>6</td>
</tr>
<tr>
<td>1.4</td>
<td>Presentation of Supporting Information</td>
<td>6</td>
</tr>
<tr>
<td>1.5</td>
<td>Privacy Notice</td>
<td>7</td>
</tr>
<tr>
<td>1.5.1</td>
<td>Data Processing of LABCAR-OPERATOR V5.4.13</td>
<td>7</td>
</tr>
<tr>
<td>1.5.2</td>
<td>Data and Data Categories</td>
<td>7</td>
</tr>
<tr>
<td>1.5.3</td>
<td>Technical and Organizational Measures</td>
<td>7</td>
</tr>
<tr>
<td>1.6</td>
<td>The LABCAR-OPERATOR V5.4.13 documents</td>
<td>8</td>
</tr>
<tr>
<td>2</td>
<td>LABCAR-OPERATOR – An Overview</td>
<td>9</td>
</tr>
<tr>
<td>2.1</td>
<td>Requirements of the Test System</td>
<td>9</td>
</tr>
<tr>
<td>2.1.1</td>
<td>Development of Controller Functionality and its Validation</td>
<td>9</td>
</tr>
<tr>
<td>2.1.2</td>
<td>The General Architecture of a Test System</td>
<td>11</td>
</tr>
<tr>
<td>2.2</td>
<td>LABCAR-OPERATOR</td>
<td>12</td>
</tr>
<tr>
<td>2.2.1</td>
<td>The Components of LABCAR-OPERATOR V5.4.13</td>
<td>13</td>
</tr>
<tr>
<td>2.2.2</td>
<td>LABCAR-IP</td>
<td>15</td>
</tr>
<tr>
<td>2.2.3</td>
<td>ETAS Experiment Environment</td>
<td>18</td>
</tr>
<tr>
<td>2.2.4</td>
<td>Migration of Older Projects (V3.2.x and Higher)</td>
<td>21</td>
</tr>
<tr>
<td>3</td>
<td>Installation</td>
<td>22</td>
</tr>
<tr>
<td>3.1</td>
<td>Preparation</td>
<td>22</td>
</tr>
<tr>
<td>3.1.1</td>
<td>Scope of Delivery</td>
<td>22</td>
</tr>
<tr>
<td>3.1.2</td>
<td>System Requirements</td>
<td>22</td>
</tr>
<tr>
<td>3.1.3</td>
<td>Further Software Requirements</td>
<td>23</td>
</tr>
<tr>
<td>3.1.4</td>
<td>User Privileges</td>
<td>23</td>
</tr>
<tr>
<td>3.1.5</td>
<td>Displaying HTML-based Content under Windows XP SP2</td>
<td>24</td>
</tr>
<tr>
<td>3.2</td>
<td>Program Installation</td>
<td>25</td>
</tr>
<tr>
<td>3.2.1</td>
<td>Start Menu</td>
<td>26</td>
</tr>
<tr>
<td>3.2.2</td>
<td>Selecting Program Versions</td>
<td>27</td>
</tr>
<tr>
<td>3.3</td>
<td>Licensing</td>
<td>31</td>
</tr>
<tr>
<td>3.3.1</td>
<td>LABCAR License Models</td>
<td>31</td>
</tr>
<tr>
<td>3.3.2</td>
<td>How to Get a License</td>
<td>31</td>
</tr>
<tr>
<td>3.4</td>
<td>HSP Update Tool</td>
<td>33</td>
</tr>
<tr>
<td>3.5</td>
<td>The Network Connection to the Real-Time PC</td>
<td>34</td>
</tr>
<tr>
<td>4</td>
<td>Tutorial</td>
<td>35</td>
</tr>
<tr>
<td>4.1</td>
<td>The &quot;IdleController&quot; Model</td>
<td>36</td>
</tr>
<tr>
<td>4.2</td>
<td>Creating the LABCAR-OPERATOR Project</td>
<td>37</td>
</tr>
<tr>
<td>4.3</td>
<td>Displaying Measure Values and Calibrating Parameters</td>
<td>43</td>
</tr>
<tr>
<td>4.4</td>
<td>Configuring Hardware</td>
<td>49</td>
</tr>
<tr>
<td>4.5</td>
<td>Adding Imports</td>
<td>52</td>
</tr>
<tr>
<td>4.6</td>
<td>Connecting Signals in the Connection Manager</td>
<td>54</td>
</tr>
<tr>
<td>4.7</td>
<td>Configuration of the Real-Time Operating System</td>
<td>57</td>
</tr>
</tbody>
</table>
1 About this Document

This document addresses qualified personnel working in the fields of automobile ECU development and testing. Specialized knowledge in the areas of measurement and ECU technology is required.

This document contains information on getting started with LABCAR-OPERATOR V5.4.13.

The document consists of the following chapters:

- "About this Document" on page 5
  This chapter
- "LABCAR-OPERATOR – An Overview" on page 9
  This chapter provides you with an overview of the requirements made of test systems for controllers in the automotive sector and the resulting architecture of LABCAR-OPERATOR and its components.
- "Installation" on page 22
  This chapter contains information on the scope of delivery, hardware and software requirements for installation and on how to prepare for the installation.
- "Tutorial" on page 35
  This chapter uses a simple example to show you how to create a LABCAR-OPERATOR project and then work with it.
- "ETAS Network Manager" on page 69
  This chapter describes the ETAS Network Manager that helps you address ETAS hardware in your network.

1.1 Classification of Safety Messages

The safety messages used here warn of dangers that can lead to personal injury or damage to property:

- **DANGER**
  indicates a hazardous situation with a high risk of death or serious injury if not avoided.

- **WARNING**
  indicates a hazardous situation of medium risk, which could result in death or serious injury if not avoided.

- **CAUTION**
  indicates a hazardous situation of low risk, which may result in minor or moderate injury if not avoided.
1.2 Presentation of Instructions

The target to be achieved is defined in the heading. The necessary steps for his are in a step-by-step guide:

Target definition

1. Step 1
2. Step 2
3. Step 3
> Result

1.3 Typographical Conventions

Software

**OCI_CANTxMessage msg0 =** Code snippets are presented in the Courier font.
Meaning and usage of each command are explained by means of comments. The comments are enclosed by the usual syntax for comments.

Choose **File → Open.** Menu commands are shown in boldface.
Click **OK.** Buttons are shown in boldface.
Press **<ENTER>.** Keyboard commands are shown in angled brackets in small caps.
The “Open File” dialog box is displayed.
Select the file **setup.exe.** Names of program windows, dialog boxes, fields, etc. are shown in quotation marks.

A **distribution** is always a one-dimensional table of sample points.

1.4 Presentation of Supporting Information

**NOTE**

Contains additional supporting information.
1.5 Privacy Notice

1.5.1 Data Processing of LABCAR-OPERATOR V5.4.13

Please note that personal data or data categories are processed when using the LABCAR-OPERATOR V5.4.13.

NOTE

The purchaser of the LABCAR-OPERATOR V5.4.13 is responsible for the legal conformity of processing the data in accordance with Article 4 No. 7 of the General Data Protection Regulation (GDPR).

As the manufacturer, ETAS GmbH is not liable for any mishandling of this data.

1.5.2 Data and Data Categories

When using the ETAS License Manager in combination with user-based licenses, particularly the following personal data or data categories are recorded for the purposes of license management:

- Communication data: IP address
- User data: User ID

1.5.3 Technical and Organizational Measures

The LABCAR-OPERATOR V5.4.13 does not encrypt the collected personal or person-related data.

Please ensure the data security of the recorded data by suitable technical or organizational measures of your IT system, e.g. by classical anti-theft and access protection on the hardware.
1.6 The LABCAR-OPERATOR V5.4.13 documents

The following LABCAR-OPERATOR V5.4.13 documents are available:

- LABCAR-OPERATOR V5.4.13 - Getting Started
  This document
- LABCAR-OPERATOR V5.4.13 - User Guide
  This document contains a complete description of all LABCAR-OPERATOR V5.4.13 functions including instructions on how to operate these functions.
- LABCAR-RTC V5.4.13 - User Guide
  This document describes the creation and parameterization of hardware configurations for HiL test systems.

The documents are provided as PDF files on your installation DVD and can also be accessed using the Help menu. Using the index, full-text search, and hypertext links, you can find references fast and conveniently.
2 LABCAR-OPERATOR – An Overview

This chapter provides you with an overview of the requirements made of test systems for controllers in the automotive sector and the resulting architecture of LABCAR-OPERATOR and its components.

2.1 Requirements of the Test System

This section deals with the requirements made of the test system and the resulting architecture. A test system is a system which is used to validate and verify the unit referred to as "controller".

2.1.1 Development of Controller Functionality and its Validation

Fig. 2-1 shows the controller as it is embedded in the vehicle and how it interacts with it. In addition, the overall model also involves the interaction of the vehicle with the driver and the interaction of the driver and the vehicle with the environment.

The block referred to as 'controller' in the control engineering description in Fig. 2-1 basically contains the control algorithms, the monitoring and diagnostic functions. It can also have interfaces to the outside world which do not interact with the other components, e.g. diagnostics and measure and calibration interfaces.

An important requirement for testing controller functionality is the simulation of driver, vehicle and environment, or DVE for short. Tools which make systematic and automated tests possible are also necessary.

Another factor which has to be taken into consideration is that, during its development, an increasing number of "interfaces" have to be operated for the controller (referred to more generally hereafter as the "unit under test" (UuT)) and parts of the DVE simulation are replaced by real components (actuators, sensors).

If the UuT initially consists entirely of control algorithms, other interfaces are gradually added as development progresses:

- monitoring and diagnostics
- calibration
The UuT is subjected to major modifications, especially in terms of its complexity, during its development. It starts as a model of a subfunctionality and extends (via the physical ECU) to a complete ECU network.

**The Evolution of the UuT in the Development Process**

Fig. 2-2 shows the different levels of complexity the UuT runs through during its development.

- **Software component and subsystem**
  In this stage of development, the UuT consists of a software model of a controller functionality.

- **Microcontroller and ECU**
  In the next two stages, the UuT consists of a hardware controller or a complete ECU. Here, the UuT is either software realized on a target (microcontroller) or it is already present physically as an ECU.

- **ECU network of a vehicle subsystem or the overall vehicle**
  At the highest stage, the UuT consists of networks of ECUs which control subsystems of the vehicle or the entire vehicle.
2.1.2 The General Architecture of a Test System

This results in the general architecture of a test system for controller development shown in Fig. 2-3.

- In the center is the experiment which is composed of the UuT and the simulation of driver, vehicle and environment (DVE).
- This experiment is managed, controlled and assigned an instrumentation by the experiment software.
- This experiment software can usually be addressed with an automation tool which enables complex, automated tests and test evaluation.
- A modeling tool is used to create and edit the DVE model or modeled controller functionality.
- Measurement and calibration tools enable direct access to the UuT.
- Diagnostic interfaces of the UuT are accessed with a diagnostic tool.

This architecture provides all functionalities of a test system that are usually necessary for managing and controlling the experiment, adapting the model to the changing stages of development of the UuT and accessing interfaces of the UuT.
2.2 LABCAR-OPERATOR

LABCAR-OPERATOR was developed taking into consideration the fundamental requirements described above of a system for developing and validating controller functionality.

Its main functions are:

• Integration platform (LABCAR-IP) for function modules of various kinds:
  – MATLAB/Simulink models
  – ASCET modules
  – I/O hardware modules
  – C code modules
  – CAN, LIN and FlexRay modules
  – Network modules
  – FiL modules
  – modules for open-loop access and signal handling

• ETAS Experiment Environment (ETAS EE) for Hardware-in-the-Loop applications with
  – comprehensive instrumentation possibilities
  – real-time Signal Generator and Datalogger
  – visualization of the data flow from the ECU via the I/O hardware, sensor/actuator configuration and simulation model
  – add-ons for accessing the ECU via measure and calibration or diagnostic interfaces (INCA)

• Remote control of tests with LABCAR-AUTOMATION
2.2.1 The Components of LABCAR-OPERATOR V5.4.13

Fig. 2-4 shows the structure and components of LABCAR-OPERATOR V5.4.13.

**Fig. 2-4** Architecture of LABCAR-OPERATOR V5.4.13
This section describes the LABCAR-OPERATOR V5.4.13 add-ons shown in Fig. 2-4.

2.2.1.1 LABCAR-MCA V5.4.13 (Modeling Connector for ASCET)
In LABCAR-OPERATOR V5.4.13, ASCET projects that were previously exported from ASCET (V6.0.1) for the target "RTPC" can now also be integrated as modules. After code generation in LABCAR-IP, the measure variables and parameters are available in the experiment environment ETAS EE.

2.2.1.2 LABCAR-MCS V5.4.13 (Modeling Connector for Simulink)
The Modeling Connector for Simulink makes it possible to use Simulink models directly - with a minimum of extensions to the model. The project is managed entirely in LABCAR-OPERATOR. All project information and configurations are created and stored here.

The Simulink model can be used both for Model-in-the-Loop and Hardware-in-the-Loop experiments. The model has what are referred to as LABCAR Inports and LABCAR Outports for both uses: These make it possible to connect model signals to each other but also model signals to hardware signals.

For HiL applications, there is a Connection Manager available for exactly this purpose. This is where the user can see both all inputs and outputs of the Simulink model (if they have been assigned LABCAR Inports and Outports) and the signals of the configured hardware. The connections between the model and the hardware are created and edited here.

This configuration is saved in the project context of LABCAR-OPERATOR - the Simulink model is unaffected by the relevant hardware configuration. This means that connections to the hardware can be modified as required without the model code having to be regenerated. Only the code for the modified hardware or for the changed connections in the Connection Manager has to be regenerated.

The user also has a default OS configuration at his disposal - changes to OS configurations should be executed in OS Configurator by experts.

2.2.1.3 LABCAR-RTC V5.4.13 (Real-Time Execution Connector)
LABCAR-RTC V5.4.13 has to have been installed if you want to use LABCAR-OPERATOR V5.4.13 with hardware components in real-time experiments.

The Real-Time Execution Connector is used to integrate and parameterize hardware components used in HiL tests. In online mode, the signal flow through the hardware channels can also be visualized and hardware settings adjusted. The saved hardware information is displayed in the LABCAR-OPERATOR environment.

2.2.1.4 LABCAR-CCI V5.4.13 (Calibration Connector for INCA)
LABCAR-CCI V5.4.13 enables the user to connect the LABCAR experiment with an INCA project to be able to access INCA data in the experiment - INCA labels of the experiment are available for visualization in LABCAR-OPERATOR V5.4.13.
Together with the ETAS measuring and calibration tools, this makes direct ECU access possible - interfaces are also available for the remote control of INCA via LABCAR-OPERATOR V5.4.13.

**NOTE**

An INCA license is not part of the delivery package.

### 2.2.1.5 LABCAR-NIC V5.4.13 (Network Integration CAN)

LABCAR-NIC V5.4.13 makes it possible to configure a simulated residual CAN bus and to exchange CAN messages with the bus in the experiment.

### 2.2.1.6 LABCAR-NIL V5.4.13 (Network Integration LIN)

LABCAR-NIL V5.4.13 makes it possible to configure a simulated residual LIN bus and to exchange LIN messages with the bus in the experiment.

### 2.2.1.7 LABCAR-NIF V5.4.13 (Network Integration FlexRay)

LABCAR-NIF V5.4.13 enables you to integrate data extracted previously using the EB tresos Busmirror into your LABCAR-OPERATOR project in order to be able to work with the signals of the FlexRay module.

### 2.2.1.8 LABCAR-LCE V5.4.13 (LABCAR Integration ETK)

LABCAR-LCE V5.4.13 enables the creation and integration of FiL modules. In an FiL system, some (or all) electric connections are bypassed and the ECU memory is accessed directly – the ECU must be equipped with an ETK for this purpose.

### 2.2.1.9 LABCAR-LCX V5.4.13 (LABCAR Integration XCP)

LABCAR-LCX V5.4.13 enables the creation and integration of FiL modules for the direct ECU access via XETK or XCP on CAN.

### 2.2.2 LABCAR-IP

The integration platform of LABCAR-OPERATOR V5.4.13 is mainly used to

- import modules with different functions into one project,
- configure the I/O hardware module,
- connect between these modules, and
- generate code for the simulation target 'RTPC'.

In addition, the following take place:

- OS settings are made for real-time simulation
- Signal Generator Sets are created for stimulating inputs in open-loop experiments
2.2.2.1 The User Interface

The LABCAR-IP user interface consists of the following:

- The Project Explorer, which contains all parts of the LABCAR-OPERATOR project
- The main workspace, which makes the important parts of LABCAR-IP accessible (via a range of tabs):
  - the general project information
  - the Connection Manager for connecting signals and inserting modules for signal conversion
  - the CAN Editor for configuring the residual bus simulation (only if LABCAR-NIC V5.4.13 is installed and the CAN module has been opened)
  - the LIN Editor for configuring the residual bus simulation (only if LABCAR-NIL V5.4.13 is installed and the LIN module has been opened)
  - the FlexRay Editor for configuring the residual bus simulation (only if LABCAR-NIF V5.4.13 is installed and the FlexRay module has been opened)
  - the OS Configuration for configuring the operating system
  - the FiL Wizard for configuring FiL modules
- The "Messages" window, with information, error messages etc. on actions and connected hardware.
2.2.2.2 Modules

A module consists of:

- signal inputs
- signal outputs
- functionality (in the form of code)
- measure variables
- parameters
- processes, the execution of which is planned in the task administration of the real-time experiment

The following kinds of modules can be used in LABCAR-OPERATOR V5.4.13:

- ASCET models
  ASCET models can be integrated with LABCAR-MCA V5.4.13.
- Simulink models
  Simulink models can be integrated with LABCAR-MCS V5.4.13.
- C code modules
  Any user-specific C code can also be integrated as a module.
- CAN modules
  Modules for the residual bus simulation can be created and processed with LABCAR-NIC V5.4.13 (Network Integration CAN).
- LIN modules
  Modules for the residual bus simulation can be created and processed with LABCAR-NIL V5.4.13 (Network Integration LIN).
- Network modules
  The Network module provides configurations of residual bus simulations using different network types.
- FlexRay modules
  Modules for the simulation of a FlexRay bus can be integrated using LABCAR-NIF V5.4.13 (Network Integration FlexRay).
- FiL modules
  Modules for ECU access with an ETK/XETK can be created and integrated with LABCAR-LCE V5.4.13.
- Hardware module
  The familiar RTIO module for configuring the I/O hardware; is created and can be edited with LABCAR-RTC V5.4.13 (Real-Time Execution Connector).
- Modules for signal conversion
  Newly introduced in LABCAR-OPERATOR V5.4.13, this considerably simplifies the modeling of sensors/actuators in open-loop operation.
2.2.3 ETAS Experiment Environment

ETAS Experiment Environment (ETAS EE) is the environment for configuring (instrumentation, parameterization etc.) and executing experiments. The new experiment environment offers the following possibilities:

- clear access to all parameters and measure variables due to the combination of the “Element List” and “Signal Center” in the “Workspace Elements” window
- creation of instrumentations for displaying measure variables and for modifying parameters of the running experiment
- signal conversion and sensor/actuator modeling
- tracing signal paths
- data recording with the Datalogger
- stimulating inputs with the Signal Generator
2.2.3.1 The "Workspace Elements" Window

In LABCAR-OPERATOR V5.4.13, the "Element List" and the "Signal Center" have been combined in a single view, "Workspace Elements".

![Diagram of Workspace Elements](image)

Fig. 2-5 A Section of "Workspace Elements"

This is where the user can access
- measure variables
- parameters
- inputs
- outputs
- hardware pins

of the active experiment.

In this view it is easy to search signals, parameters and measure variables, as well as the hierarchies of the modules. The filter function and search function of the "Workspace Elements" window also help you.
2.2.3.2 Instrumentation
The set of instruments for displaying measure variables and inputting parameters has been extended considerably: A new real-time oscilloscope has also been developed.

2.2.3.3 Open-Loop Operation and Signal Editing
The resolute standardization of the parts of the HiL experiment in the form of modules makes systematic intervention in the signal trace possible.

Generic actuator/sensor modules (based on C code modules) can be used at any point in the signal trace. Every input can be used to interrupt the signal chain and to stimulate the input with constant values or values from the Signal Generator.

ETAS EE contains the "Signal List" for managing, tracing and editing signals.

Once a signal has been added to the Signal List, the following actions can be carried out here:

- tracing the signal trace
- defining the mode: model, constant value or connection of a Signal Generator for open-loop operation.
2.2.4 Migration of Older Projects (V3.2.x and Higher)
Projects created with LABCAR-OPERATOR V3.2.x and higher have automatically been migrated up to LABCAR-OPERATOR V5.1.2. This is no longer possible from version V5.2.x.

**NOTE**
If you want to open such a project with LABCAR-OPERATOR V5.4.13, you must first open it in version V5.1.x, migrate it and re-save it.

When the old project is opened in LABCAR-IP, the "Migration Wizard" is launched – it executes all necessary steps.

The successfully migrated project is then stored in the directory previously selected under the selected name.

**Limitations**
The automatic migration of projects does not work if

- the project (LABCAR-OPERATOR V3.2.x) contains a LABCAR-DEVEL-OPER project or
- with projects with simulation target ES1130

This kind of project must be recreated in LABCAR-OPERATOR V5.4.13.
3 Installation

This chapter contains information on the scope of delivery, hardware and software requirements for installation and on how to prepare for the installation.

3.1 Preparation

Check that the delivery package you receive contains everything it should and that your PC meets the system requirements. Depending on the operating system and network connection, you have to ensure that you have the necessary user privileges.

**NOTE**
Artefacts of LABCAR software projects contain personal data (e.g. user name of the creator or operator). An example are log files generated during runtime. Therefore the user is responsible for compliance with (local) laws and regulations, like the fulfillment of legal requirements for deletion of personal data.

3.1.1 Scope of Delivery

LABCAR-OPERATOR V5.4.13 is supplied with the following:

- LABCAR-OPERATOR V5.4.13 DVD-ROM
  - LABCAR-OPERATOR V5.4.13 program files
  - The current Hardware Service Pack (HSP)
  - LABCAR-OPERATOR V5.4.13 manuals in PDF format
  - Manuals of current LABCAR hardware in PDF format
  - What’s New, Release Notes and additional documentation
- The "LABCAR-OPERATOR V5.4.13 - Getting Started" manual
- A document ("License Entitlement") that describes how to get the licenses for the software components purchased.

3.1.2 System Requirements

The following system requirements are necessary for the operation of LABCAR-OPERATOR V5.4.13:

- Hardware:
  - Intel Pentium Dual-Core 2 GHz processor or higher
  - Min. 4 GB RAM; 8 GB recommended
  - Hard disk 20 GB (at least 5 GB free space)
  - DVD-ROM drive (for the installation)
  - Graphics card compatible with DirectX 9 or higher - resolution 1280x1024, 16-bit colour or higher
  - Ethernet board (10/100BaseT)
• Operating systems:
  – Windows 7 SP1 (32-bit or 64-bit)
  – Windows 8.1 (64-bit)
  – Windows 10
The following language versions of these operating systems are supported:
  – English
  – German
  – French
  – Japanese
  – Korean

3.1.3 Further Software Requirements
The current list of the software versions required for operating LABCAR-OPERATOR V5.4.13 is in the menu ? → Help in the document "LABCAR-OPERATOR 5.x.y - Software Compatibility List".

3.1.4 User Privileges
Please observe the following information on user privileges required for installation and operation of LABCAR-OPERATOR.

3.1.4.1 User Privileges Required for Installation
  • You must have administrator privileges to install products of LABCAR-OPERATOR on a PC. If in doubt, ask your system administrator.
  • You must have a directory for temporary files on your PC (e.g. C:\TEMP) to which all users working with LABCAR-OPERATOR on this PC have both read and write access.

3.1.4.2 User Privileges Required for Operation
  • To work with products of LABCAR-OPERATOR, every user has to receive the "Increase Scheduling Priority" privilege from the administrator. If you have already installed INCA, you may well have already organized this for some users during installation (see figure).
• All LABCAR-OPERATOR users must have write access to the registration key “HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Cryptography\RNG” as well as full access to the “HKEY_LOCAL_MACHINE\SOFTWARE\ETAS” key and the keys of all subdirectories.

• All users of LABCAR-OPERATOR and the default user “Everyone” must have full access rights to the \ETAS folder, its subfolders and all the files in them. This is absolutely necessary for code generation with the GNU C-Compiler.

3.1.5 Displaying HTML-based Content under Windows XP SP2

Make sure that the “Allow active content to run in files on My Computer” option is enabled.

These settings are in the Control Panel under “Internet Properties” in the “Advanced” tab.
3.2 Program Installation

This section describes how to install LABCAR-OPERATOR V5.4.13.

To install LABCAR-IP:

1. Insert the product DVD in your DVD-ROM drive.
   The DVD-Browser is launched.

2. Select
   **Installation → Install LABCAR-OPERATOR**.
   You can install the HSP (Hardware Service Pack) later (see
   “HSP Update Tool” on page 33).
   The welcome window opens.

3. Click **Next** and follow the instructions of the installation wizard.
4. To complete the installation click Finish.

3.2.1 Start Menu
The Start menu folder All Programs → ETAS → LABCAR-OPERATOR X.Y contains the following entries once installation has been completed successfully:

- LABCAR-IP
  Launches the integration platform
- LABCAR-OPERATOR Tools
  Opens the LABCAR-OPERATOR directory \LCO \Tools, from where the following tools can be started:
  - LABCAR-OPERATOR Version Selector
    This is where you can toggle between the versions (see “To select the LABCAR-OPERATOR version” on page 28)
  - MATLAB Version Selector
    This is where you can select the MATLAB® version to be used (see “To select the MATLAB version” on page 28)
  - RT-Plugin Builder
    Starts an application for creating real-time plugins.
• Manuals and Tutorials
  Opens an File Explorer window for \ProgramData\ETAS\ETASManuals\, which contains a link to the manuals of LABCAR-OPERATOR and LABCAR hardware.

The Start menu folder All Programs → ETAS → Experiment Environment X.Y contains the following entries:

• Experiment Environment VX.Y Tools
  Opens the Experiment Environment directory \EE Tools, from where the following tools can be started:
  – Associate to INCA
    Opens a dialog window which connects ETAS EE with a specific INCA version (see “To select the INCA version” on page 29).
  – Associate to RTA Trace
    Opens a dialog window which connects ETAS EE with a specific RTA Trace version.
• Experiment Environment VX.Y
  Launches the experiment environment ETAS EE.
• Manuals and Tutorials
  Opens an File Explorer window for \ProgramData\ETAS\ETASManuals\, which contains a link to the HTML help documents for ETAS EE.
• TargetServernn Tools
  Opens the directory \ETAS\TargetServernn\Tools, from where the following tools can be started:
  – Search for connected hardware
    The target server is launched and a search for connected hardware is executed.
  – ETAS Network settings
    Launches the ETAS Network Manager for configuring your network card(s) for the ETAS hardware and other networks (see “ETAS Network Manager” on page 69).

3.2.2 Selecting Program Versions
To complete the installation, you should now specify which versions of the software employed in the LABCAR-OPERATOR environment should be used. This applies both to the LABCAR-OPERATOR version itself and the version of Matlab/Simulink and INCA.

For the current list of the software versions refer to “Further Software Requirements” on page 23.
To select the LABCAR-OPERATOR version
If you have installed several versions of LABCAR-OPERATOR, you can specify the version to be used. To do so, proceed as follows:

1. If LABCAR-IP is open, close it.
2. From the Windows Start menu, select Programs → ETAS → LABCAR-OPERATOR X.Y → LABCAR-OPERATOR VX.Y Tools → LABCAR-OPERATOR Version Selector.
   The LABCAR-OPERATOR Version Selector opens.
3. Select the version to be used and click Switch.
   If the change is successful, the following message is displayed.

![Switching LCO Version Message](image)

**NOTE**
Always use the LABCAR Version Selector from the current LABCAR-OPERATOR version – otherwise double registry entries may cause problems.

To select the MATLAB version
If you have installed several versions of Matlab/Simulink, you can specify the version to be used (in the integration of Simulink models). To do so, proceed as follows:

1. From the Windows Start menu, select All Programs → ETAS → LABCAR-OPERATOR X.Y → LABCAR-OPERATOR VX.Y Tools → Matlab Version Selector.
   The “Select Matlab Version” window opens.
2. Select the version to be used from the “Installed Matlab Versions” list.
3. To display the versions supported by LABCAR-OPERATOR V5.4.13, click Supported Matlab Versions.
4. To save your selection, click Select.
   The successful selection is confirmed.
5. Click OK to exit the Matlab Version Selector.

To select the INCA version
If you have installed several versions of INCA, you can specify the version to be used (for accessing INCA experiments with LABCAR-CCI V5.4.13). This selection is executed during installation of the experiment environment (ETAS EE) but can be changed at any time. To do so, proceed as follows:

1. From the Windows Start menu, select All Programs → ETAS → Experiment Environment X.Y → Experiment Environment VX.Y Tools → Associate to INCA.
   The "Associate to INCA" window opens.

2. Select the version to be used from the list.
3. To save your selection, click Associate.
4. The installation of the ETAS Target Server starts.
5. Follow the instructions of the installation routine.
6. If applicable, enter any other users who should also have the right to increase scheduling priority.
   For more details see “User Privileges Required for Operation” on page 23.

7. Click **Next**.

8. The target server is installed.
3.3 Licensing

To be able to work with an ETAS software product, you require a license. This section contains basic details on this subject. Details concerning the scope of the licenses and other legal aspects can be found in “Terms and Conditions”.

3.3.1 LABCAR License Models

There are two different license models available for licensing your LABCAR software:

3.3.1.1 Machine-Named License, Local

- A license of this type is managed by the user him/herself.
- As it is linked to a particular PC (better: to the MAC address of the Ethernet adapter), it is valid wherever the PC is used.
- When you change your PC, you require a new license.

3.3.1.2 Concurrent (or Floating) License, Server-Based

Most of what is true of the user-named license applies to this type of license. The difference is that here several users share a limited number of licenses.

3.3.2 How to Get a License

If your company has a tool coordinator and server-based license management for ETAS software, contact this person. Otherwise (in the case of a machine-named license) you obtain your license from the ETAS license portal (the URL is shown on your Entitlement Certificate).

There are three ways of logging in on the welcome page:

- Activation ID
  Once you have logged in, a specific activation¹ is visible and can be managed – the activation ID is shown on your Entitlement Certificate.
- Entitlement ID
  All activations of the entitlement² are visible and can be managed (e.g. for a company with just one entitlement).
- E-mail and password
  All activations of the entitlements assigned to the user account are visible and can be managed (e.g. for a tool coordinator responsible for several entitlements).

If you need help in the portal, click the Help link.

¹. The activations refer to a specific product, its license conditions, the available number of licenses and other details required for generating a license. Activations are identified uniquely with activation IDs.
². An entitlement shows the authorizations you have as a user; it stands for the right to own one or more licenses for a product. It is a kind of account of rights of use for software from which you can take licenses as you need to.
3.3.2.1 What Information is Required?
Information on the hosts must be entered to activate licenses:

- Machine-named license
  The MAC address of the Ethernet adapter to which the license is to be bound is required here
- Concurrent (floating) license
  Here, you need a server host or a server triad.

NOTE
If this data changes (e.g. due to changes in the hardware or a change of user), the license must be given a "rehost". This procedure is also described in the portal help file.

3.3.2.2 License File
The result of your activities is the provision of a file `<name>.lic` with which you can license your software in the ETAS License Manager.

To check license status
1. In the Windows Start menu, select in the app list **E → ETAS → ETAS License Manager**.
   The ETAS License Manager is opened.
   The ETAS License Manager contains one entry for each installed product. The symbol at the beginning of the entry and the "Status" column entry indicate whether a valid license has already been obtained or not.

2. Further information on license management can be found in the online help (<F1>).
3.4 HSP Update Tool

The HSP Update Tool is supplied so you can update your hardware to the latest firmware version (with the most recent Hardware Service Pack from your product DVD).

**To execute installation**

1. Insert the product DVD in your DVD-ROM drive.
   
   The DVD browser is launched.

2. Select **Installation → Install HSP <version no.>**.

3. Click **Next**.
   
   The installation procedure starts.

4. Follow the instructions in the dialog boxes.

5. Click **Finish** to complete the installation.
To run a firmware update

1. Launch the HSP Update Tool in LABCAR-IP using **Tools → HSP Update Tool**.

   ![HSP Update Tool](image)

   The HSP Update Tool is launched.

2. Select **Help → Quick Start**.

   A help window with instructions on running the update opens.

3. Run the firmware update as described.

3.5 The Network Connection to the Real-Time PC

The connection between your user PC and the target "RTPC" takes place via a second Ethernet board in the user PC and the "ETH0" port of your Real-Time PC. Then configure the board in your user PC with the fixed network address 192.168.40.240 (subnet mask: 255.255.255.0).

For more details refer to the "ETAS RTPC V6.5.2 - User Guide" and the chapter "ETAS Network Manager" on page 69.
4 Tutorial

This chapter uses a simple example to show you how to create a LABCAR-OPERATOR project and then work with it.

This tutorial is structured as follows:

- "The "IdleController" Model" on page 36
  This section contains a short description of the Simulink model "IdleController.mdl" used for this project.

- "Creating the LABCAR-OPERATOR Project" on page 37
  This section describes the basic steps when creating a project with LABCAR-MCS V5.4.13 (Modeling Connector for Simulink).

- "Displaying Measure Values and Calibrating Parameters" on page 43
  In this section, you will create a display element for engine speed and a switch with which the air conditioning can be switched on and off.

- "Configuring Hardware" on page 49
  The scope of this tutorial does not allow for creating a real HiL experiment – this section demonstrates how to work with the tools and use the functions of LABCAR-MCS in this sphere of implementation.

- "Adding Inports" on page 52
  Before you can connect the hardware with model signals, you must add LABCAR inports or outports to the model.

- "Connecting Signals in the Connection Manager" on page 54
  The signal of the A/D converter ("0" or "1") is then connected to the model input "AirConditionManual" in the Connection Manager.

- "Configuration of the Real-Time Operating System" on page 57
  LABCAR-OPERATOR creates a standard OS configuration for every new project in which all the necessary tasks are available and all processes are assigned accordingly.

- "Running the Experiment" on page 58
  This section contains a description of the last steps you take before running the experiment.

- "Recording with the Datalogger" on page 64
  This section contains instructions on how to record signals with the Datalogger.
4.1 The "IdleController" Model

This section contains a short description of the Simulink model "IdleController.mdl" used for this project.

Fig. 4-1 shows the Simulink model used; it consists of a simple engine model, "Pedal2Nengine", and the actual idle controller "A_IdleController".

The input of the controller is the accelerator position from the driver and the engine speed; a pre-defined speed is maintained during idling.

Fig. 4-1 The Overall Model "IdleController.mdl"

In the actual engine model (Fig. 4-2) the accelerator position ("Accelerator_input") is used to calculate the torque which in turn is used to calculate the engine speed. It is also possible to additionally activate air conditioning which of course requires torque and – particularly during idling - lowers the engine speed. The idle controller becomes active when the engine speed decreases; it provides the engine model with a corrected accelerator position to ensure that the engine speed is readjusted to the target speed required.

The air conditioning is switched according to the value of "AirConditionManual" at the top left in Fig. 4-2. In this tutorial, this value is first modified using a control window and then applied using A/D converter hardware.

Fig. 4-2 The "Pedal2Nengine" Engine Model
4.2 Creating the LABCAR-OPERATOR Project

This section describes the basic steps when creating a project with LABCAR-MCS V5.4.13 (Modeling Connector for Simulink).

To launch LABCAR-OPERATOR

1. Select Start → Programs → ETAS → LABCAR-OPERATOR X.Y → LABCAR-IP.

or

1. Double-click the program icon on your desktop.

LABCAR-OPERATOR is launched and the main window opened.

A detailed description of this user interface is contained in the LABCAR-OPERATOR V5.4.13 - User Guide.
To create a LABCAR-OPERATOR project

1. Select **File → New Project**.

   The Project Wizard opens.

2. Select a directory under "Location" in which the new project is to be created.

3. Enter a project name under "Project Name".

4. If necessary, assign this target a special name under "Target Name".

5. Click **Finish**.

   The project (without modules and hardware) is created.

To integrate a Simulink model

1. Select **Project → Add Module**.

   or

1. Select the **Add Module** icon.

   or

1. Right-click the Target "RTPC" and select **Add Module** from the shortcut menu.

   The Add Module Wizard opens.
2. Select the "Add Simulink (TM) Module" option.

3. Click **Next**.

4. Select "Use existing Simulink (TM) Model".
5. Click **Next**.

6. Use **Browse** to select the Simulink model you want to use.

   The "IdleController.mdl" model is in the directory
   `<drive>:\Program Files\ETAS\LABCAR-OPERATORX.Y\Manuals\Tutorial`.

7. When the option „Copy Model Directory into Project“ is
   selected, the Simulink model and all corresponding files are
   copied into the project directory – otherwise the model is only
   referenced.

8. You can make further settings regarding external files and
   directories using **Advanced Settings** (see LABCAR-OPERATOR V5.4.13 - User Guide) - this is not necessary, however, for
   this example.

9. Select **Finish**.

   > The project is created and the relevant directories and files cre-
   ated on your hard disk.

   The directory tree of the project is created in the Project
   Explorer.

Once the project has been created, the code can be generated.

**NOTE**

Make sure that your experimental target is correctly connected and opera-
tional!
To generate code

1. Select **Project → Build...**

or

1. Click the **Build LABCAR Project** icon.

2. In the following window, select the modules for which code is to be generated.

3. Click **Build**

   > Code is generated for the selected modules.

   Successful code generation is then documented in the "Messages" tab.

With the successfully generated code, you can now open, configure and run an experiment in the ETAS EE experiment environment.

**NOTE**

Once code has been generated for the first time, ETAS EE is launched automatically and a workspace is generated for this experiment.

To start an experiment in **ETAS EE**

1. Click the **Open Experiment Environment** icon.
ETAS EE is launched and the experiment opened.

In the "Workspace Elements" window, all parameters, measure variables, inputs and outputs of the model are listed in the corresponding hierarchy.

In the main workspace, you can create the instrumentation (in several "layers"), configure and operate the Datalogger ("Datalogger" tab), and create and operate Signal Generators ("Signal Generator" tab).
4.3 Displaying Measure Values and Calibrating Parameters

In this section, you will create a display element for engine speed and a switch with which the air conditioning can be switched on and off.

To create an oscilloscope

1. To create an oscilloscope for displaying the engine speed, click the Add Oscilloscope icon in the toolbar.
   An oscilloscope window opens.
2. Search for the "TorqueToNEngine" folder in the "Workspace Elements" window (under "Search&Filter").
3. Click through the hierarchy until you see the label "TorqueToNEngine\Out".
4. Select "Out" and drag it to the oscilloscope window keeping the left-hand mouse button pressed down.
5. Release the mouse button over the oscilloscope window.
   The "Create Instruments" window opens.
6. Select "Acquisition" as task to acquire the measure variable.
7. Click OK.
The measure variable is added to the oscilloscope. The name of the variable to be shown is displayed in the legend.

You will now create a switch with which the air conditioning can be switched on and off.

**To create a switch for the air conditioning**

1. In the "Workspace Elements" window, search for the "Value" parameter in the "AirConditionManual" folder.

You can also create a control or display element as follows:

2. Right-click the "Value" parameter.

**NOTE**

Measure variables are always recorded in the raster of the task they are assigned to - if this raster is less than 5 ms, the following restrictions must be taken into consideration:

1. Continuous recording of measure variables cannot be guaranteed in this range. To ensure continuous recording of measure data, use the Datalogger.
2. The x values (= time) of the measuring points shown may not correspond exactly to this raster - there could be minimal delays.
3. Select Measure / Calibrate.

The "Create Instruments" window opens.

4. Under "Instrument Type" select "On/Off".

5. Under "Group" select "<New Group>".

6. Click OK.

The control element is created.

7. Select the inner area of the control element and go into the "Properties" window.
8. Under "Label Format", replace the character string "%Default" with "Air Condition".

> The switch now has the correct label.

9. Add the "Value" parameter to the oscilloscope.

To download an experiment to the target
1. Make sure that the simulation target specified during project creation is connected and switched on.
2. Select Experiment → Download → LABCAR.
   or
   - Click the arrow next to the Download icon and select LABCAR.
   The experiment is downloaded to the experimental target.

> Successful downloading is indicated in the log window.
To run an experiment

1. Launch the simulation with Experiment → Start Simulation → LABCAR.

   or

1. Click the arrow next to the Start Simulation icon and select LABCAR

   The measure variable is displayed in the oscilloscope.

   After a while, the idle speed stabilizes at 750 rpm.

2. To display the speed and the parameter for switching the air conditioning on and off each in their own coordinate system, right-click the coordinate system and select Single Axis per Channel.

3. To use the maximum necessary area for display for the relevant y axis, select the relevant axis.
4. Right-click and select **Zoom to Fit**.

5. If necessary, move the y axes using the mouse.

6. Now switch on the air conditioning with the "Air Condition" switch created.
   The idle speed briefly drops due to the additional torque and is then compensated by the idle controller.

7. Switch the air conditioning back off.

   The pedal position corrected by the idle controller results in the speed briefly increasing; this is then also compensated.

8. Stop the experiment by clicking the **Stop Simulation** icon.

   or

   i. Select **Experiment** → **Stop Simulation** → **LABCAR**
   ii. End the experiment by clicking the **Disconnect** icon.

   or

   iii. Select **Experiment** → **Disconnect** → **LABCAR**
   iv. Select **File** → **Save Experiment**.
   v. Select **File** → **Exit**.
Return to LABCAR-IP to configure the hardware.

4.4 Configuring Hardware

The scope of this tutorial does not allow for creating a real HiL experiment – this section demonstrates how to work with the tools and use the functions of LABCAR-MCS in this sphere of implementation.

A/D converter hardware is used here (PB1651ADC1 A/D Module on an ES1651.1 Carrier Board) – this makes it possible to use a voltage signal between 0 and 10 V to switch the air conditioning on and off.

To create a hardware configuration

1. Open LABCAR-IP
2. Select Project → RTIO Editor.
   or
3. Click the Edit Hardware Configuration icon.
   or
4. Select the hardware module and select Edit from the short-cut menu.

The RTIO Editor opens. The simulation target specified during project creation (here RTPC) is already in the HWC-Items tree.

3. Select the “Domain” system below the simulation target “RTPC”.
4. Select Edit → Add Item.
   The “Add Items” window opens.
5. Select the item "ES1651-CB".

6. Click **OK**.
   The ES1651.1 Carrier Board is added to the hardware configuration.

7. Select this new item in the "Items" list.
8. Reselect **Edit → Add Item**.
9. In the 'Add Items' window, select the item "PB1651ADC1".
10. Click **OK**.
The PB1651ADC1.1 module is added to the hardware configuration.

![Image](image1.png)

11. Select the "Signals" tab.
12. Select the signal "AnaIn_0".
13. Double-click the cell under "Operating Mode".
14. Select "Comparator" as operating mode.
15. Double-click the cell under "Threshold [V]".
16. Enter 5.0 V.

This defines the channel as comparator – with voltages < 5 V the signal assumes the value "0", otherwise "1".

![Image](image2.png)

17. Click **Accept**.
18. Select **File → Save**.
19. To close LABCAR-RTC select **File → Exit**.
4.5 Adding Inports

Before you can connect the hardware with model signals, you must add LABCAR inports or outports to the model.

To add an inport

1. In the Project Explorer, select the "IdleController" model.
2. In the shortcut menu, select Edit.

The model belonging to the project is opened in Simulink.
3. If the "Pedal2Nengine" block has not been opened yet, double-click it.

The "AirConditionManual" parameter is now to be supplied to the model using A/D converter hardware. For this to be possible, a LABCAR inport (instead of the constants) has to be added to the model for the relevant signal.

4. In Simulink select View → Library Browser.
   The Simulink Library Browser opens.
5. Open the "LABCAR Port Blocks" library.
6. Use the mouse to select an input port and drag it into the model.

7. Delete the "AirConditionManual" block.

8. Rename the LABCAR inport "AirConditionManual".

9. Connect the LABCAR inport with the free input.

10. Save the changes using File → Save.
4.6 Connecting Signals in the Connection Manager

The signal of the A/D converter ("0" or "1") is then connected to the model input "AirConditionManual" in the Connection Manager.

To launch the Connection Manager in LABCAR-OPERATOR
1. Select the "Connection Manager" tab in the main window of LABCAR-OPERATOR V5.4.13.
   The Connection Manager opens.
2. Click Update Ports to update the display of all hardware and model ports.

To create a connection between the model and the hardware
1. Use the mouse to select the hardware output ("AnalIn_0") and the model input ("AirConditionManual").
2. Click the icon to connect the selected signals.
or

- Use the mouse to select an output and move it to the desired input.
The connection is created and shown in the field "Existing Connections" (providing no filter is active preventing newly created connections from being displayed).

To indicate that this output has been connected to an input, the two ports are now shown in blue.

3. Save the changes using File → Save All.
4.7 Configuration of the Real-Time Operating System

LABCAR-OPERATOR creates a standard OS configuration for every new project in which all the necessary tasks are available and all processes are assigned accordingly.

To familiarize yourself with the OS Configurator, open it as described below – a detailed description can be found in LABCAR-OPERATOR V5.4.13 - User Guide.

To launch the OS Configurator

1. Select the "OS Configuration" tab in the main window of LABCAR-IP.
   The "OS Configuration" window opens.
2. To be able to view all information, open all elements of both tree views and click the chevron button.
3. Click Update Processes.
   The "Processes" window (on the left) lists all hardware and model processes; the "Tasks" window shows all tasks created automatically and their assigned processes.
   The automatic assignment can be accepted in this way.
4. Save the changes using File → Save.
4.8 Running the Experiment

This section contains a description of the last steps you take before running the experiment.

The individual sections are:

• “To generate code” on page 58
• “To create a new layer for instrumentation” on page 59
• “To display measure variables in the oscilloscope” on page 59
• “To open a signal chain” on page 60
• “To apply a voltage source to the ADC module” on page 62
• “To start an experiment” on page 62

To generate code

1. Make sure that the simulation target specified during project creation is connected and switched on.
2. Select Project → Build.
3. Select the modules to be created.
4. Click Build.
   Code generation for the model, the hardware configuration and the Connection Manager is started and an executable file generated.
5. Use the “Messages” tab to make sure the build process was successful.

If errors occur, a separate window containing detailed information opens.
6. Click the **Experiment Environment** icon.

   > ETAS EE is launched and the experiment opened.

**To create a new layer for instrumentation**

The "Instrumentation" tab now contains the layer just created with the oscilloscope and the switch for the air conditioning. This switch is now highlighted which shows that the assigned parameter no longer exists (because it was replaced by a LABCAR input).

1. Click the name of the layer and select **Rename Layer**.
2. Assign it, for example, the name "Experiment without hardware".
3. Click in the tab environment and select **Create Layer**.

![Image of a Layer with Rename and Create Layer options]

4. Name the new layer, for example, "Experiment with hardware".

**To display measure variables in the oscilloscope**

1. To create an oscilloscope for displaying the engine speed in the new layer, click the **Add Oscilloscope** icon in the toolbar.
2. Add the measure variable for speed, "IdleController/Pedal2NEngine/TorqueToNEngine/Out", by Drag&Drop.
3. Also add the new model input "AirConditionManual".

![Image of an Oscilloscope with Engine Speed and Air Conditioning inputs]

4. Download the experiment to the simulation target.
5. Start the simulation.

The idle speed reaches its default value and the value of "AirConditionManual" is "0" as there is no voltage at the hardware input and the D/A converter thus does not deliver an output signal.

Before using the I/O hardware, read the following section on the function of the "Signal List".

To open a signal chain

1. In the Workspace Elements select the model input created previously, "AirConditionManual".
2. Right-click and select **Signal → Trace**.

The "Select the Tracing Mode" window opens.
3. Select "backward" and "<New Group>" and click **OK**.

A new instrument of type "Signal List" opens.

You can see the connection created previously in the Connection Manager between the A/D converter module and the model port.
4. Select the inner section of the Signal List using the mouse.
5. In the "Properties" window, change "Label Format" from "%HIERARCHY0" to "%HIERARCHY2". This displays the full hierarchy of the signal names:

![Signal List](image1)

6. To temporarily interrupt this connection, select "CONST" from the list in the "Mode" column.

![Signal List](image2)

There is thus a constant value pending at this input which is specified in the "Constant" column.

7. Start the simulation.

8. Change the value in the "Constant" column to 1 (then press <Return>).

The idle speed again briefly drops and is compensated.

![Graph](image3)
9. Change the value in the "Constant" column back to "0" (then press <Return>).
   The idle speed behaves as normal and is compensated.
10. Set "Mode" back to "MODEL." for the subsequent operation with hardware.

**To apply a voltage source to the ADC module**

1. Connect a controllable voltage source (0 - max. 10 V) to the input channel 0. Consult the "PB1651ADC1 A/D Module – User's Guide" for information on the assignment of the front-facing connector.

**To start an experiment**

1. Make sure that the simulation target specified during project creation is connected and switched on.
2. Select Experiment → Download → LABCAR.
   or
   - Click the arrow next to the Download icon and select LABCAR.
   The experiment is downloaded to the experimental target.
   Once this has been executed successfully, a message is output in the "Messages" tab.
   - Select Experiment → Start Simulation → LABCAR.
   or
   - Click the arrow next to the Start Simulation icon and select LABCAR.
   The experiment is launched.
   As long as the applied voltage is under the predefined threshold, the "AirConditionManual" signal equals 0, the idle speed has the default value 750 rpm.
   "0" is also displayed as the value in the Signal List.

3. Now modify the voltage so that it is greater than the comparator threshold of 5.0 V.
   The air conditioning is switched on ("AirConditionManual" = 1), the idle speed briefly drops due to the additional torque and is then compensated.
4. Lower the voltage so that it is once again below the comparator threshold of 5.0 V.
   After an overshoot, the idle speed is adjusted.
5. Stop the experiment by clicking the **Stop Simulation** icon.

   or

   - Select **Experiment** → **Stop Simulation** → **LABCAR**.
4.9 Recording with the Datalogger

This section contains instructions on how to record signals with the Datalogger.

To record the air conditioning being switched on and off with the Datalogger, proceed as follows:

**To create a Datalogger**

1. In the ETAS EE workspace, select the "Datalogger" tab.

2. Click **Add** in the "Available Dataloggers" field.

   A new Datalogger is added

**To configure the Datalogger**

1. To add a signal to the Datalogger from the Element List, select "Out" (see figure).
2. Press the left-hand mouse button and drag the element to the "Signals to record" area.

The signal is added to the list of signals to be recorded.

3. Also add the "AirConditionManual" model input to the Datalogger.

4. Select a task according to which the Datalogger should record (here "Acquisition").

To select a file for the recorded data

The "base name" for the file in which the recorded data is to be stored is specified in the "Recording File Settings" field under "Recording base filename".

1. To select a different base file, click ...

The name of the file created after every recording is determined by the option selected under "Auto Increment".

Selecting the "Auto Increment" option results in the file name being extended by a number which is incremented automatically each time the Datalogger starts. Specify the number of digits of this number in the "Digits" field.
To start the Datalogger manually

1. Start the simulation.

2. Activate the Datalogger (in the "Active" column).

3. To start the Datalogger click the blue arrow head.

The Datalogger is started.

4. To stop the Datalogger click the blue square.

> The Datalogger is stopped and the data stored in a file (*.dat).

**To define the trigger conditions and recording duration**

If you want the recording to start (or end) automatically, you must define a trigger condition.

1. Click the ... icon at the bottom right of the "Trigger Settings" field.

The editor for trigger settings opens.
2. Under "Filter Type", select "Start Trigger Filter"

3. Select the following settings under "Trigger Condition":
   - First Operand (Signal): "AirConditionManual"
   - Operator: >
   - Threshold: 0.5
4. Under "Trigger Timing" select the following settings:
   - Pre Trigger Time: 0 s
   - Post Trigger Time: 10 s

5. Click **OK**.

6. Activate the Datalogger (in the "Active" column).

7. Now switch on the air conditioning with your voltage source.
The Datalogger starts recording data once the trigger condition occurs and stops doing so 10 s later.

<table>
<thead>
<tr>
<th>Datalogger Configuration</th>
</tr>
</thead>
<tbody>
<tr>
<td>Load</td>
</tr>
</tbody>
</table>

### Available Dataloggers

<table>
<thead>
<tr>
<th>Name</th>
<th>Active</th>
<th>State</th>
<th>Rec. Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Datalogger 1</td>
<td></td>
<td>Recording</td>
<td>9.1</td>
</tr>
</tbody>
</table>
5 ETAS Network Manager

The ETAS Network Manager is used for creating a configuration that will be used by the ETAS IP Manager. The IP Manager is responsible for dynamic IP addressing of the ETAS hardware used in your network (ETAS network).

5.1 Overview

ETAS software supports different configurations for hardware access via Ethernet:

- Using multiple network adapters:
  - one network adapter for the company network,
  - one or more network adapters for the ETAS hardware.
- Using one network adapter
  - automatic toggling between the company network and the ETAS hardware.

**NOTE**

You do not require a separate network adapter to connect the ETAS hardware to your PC. You can use the same network adapter both for the company network and the ETAS network.

The ETAS Network Manager supports you in selecting the network adapter for the ETAS hardware.

The ETAS Network Manager gives you an overview of the network adapters available for your PC and the type of IP address assignment. If more than one network adapter is available in the system, you can select the network adapter to use for connecting the ETAS hardware to your PC. You can also specify the address range for the IP assignment for the ETAS hardware.

You do not need administrator rights to select the network adapter and the network environment configuration for the ETAS hardware. You can toggle between the ETAS network and the company network without rebooting your PC.

**NOTE**

With the ETAS Network Manager, you cannot create or modify the configuration for the network adapter. Instead, modify the network settings of your PC via the Control Panel (see the documentation for your operating system). Please note that this requires administrator rights.

5.2 ETAS Hardware Addressing

You can connect several ETAS devices (including those that are the same type) to your PC. The connected devices are identified in the local ETAS network by their unique IP address.
An IP Manager integrated in the ETAS software looks up which IP addresses are available in a pre-configured address pool and assigns available IP addresses to the connected ETAS hardware.

The address range for the address pool is specified using the ETAS Network Manager.

5.3 Network Adapter Addressing

5.3.1 Type of Network Adapter Addressing
The type of network adapter addressing done within the company network depends on the operating system being used and the network adapter configuration:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Type of Network Adapter Addressing</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Manual</td>
</tr>
<tr>
<td>Windows 7</td>
<td>yes</td>
</tr>
<tr>
<td>Windows 10</td>
<td>yes</td>
</tr>
</tbody>
</table>

The ETAS network supports the following types of network adapter addressing:

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Type of Network Adapter Addressing</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Manual</td>
</tr>
<tr>
<td>Windows 7</td>
<td>yes</td>
</tr>
<tr>
<td>Windows 10</td>
<td>yes</td>
</tr>
</tbody>
</table>

If you wish to use the network adapters both for the company network and the ETAS network, you cannot use the network adapters that exclusively support DHCP addressing for this dual operation.

**NOTE**

DHCP can be used only in combination with APIPA or an alternative IP address!

5.3.2 Addressing the Network Adapter Manually
Addressing a network adapter depends on the operating system.

For instructions on addressing your PC’s network adapter, see the documentation for your operating system.

To address the network adapter manually, you need administrator rights. Please contact your system administrator, if necessary.
If the network adapter is addressed manually, i.e., it has a static IP address, it may happen that you accidentally end up searching for or initialize ETAS hardware, although the PC is connected to the company network. The Network Manager allows you to stipulate that if this happens, you are to receive a warning before an IP address is assigned to an ETAS hardware.

5.3.3 Addressing the Network Adapter via DHCP

Addressing via DHCP requires that the DHCP server be available. Should the DHCP server not be available, or if there is no DHCP server (as in the ETAS network), the network adapter has not been configured.

In this instance, each operating system has a feature that automatically assigns the network adapter an IP address:

Windows XP / Windows Vista / Windows 7

Windows XP, Windows Vista, and Windows 7 automatically check whether there is a connection to the DHCP server. If there is none, it either assigns the IP address automatically via APIPA, or it uses the user-specified alternative IP address. The ETAS network always uses either the APIPA address or the alternative IP address.

When toggling between the DHCP network and ETAS hardware, make sure that the operating system is able to detect a connection failure because only then will reconfiguration be initiated. This may take up to 10 seconds. It takes the operating system 60 seconds to entirely reconfigure from a DHCP address to an APIPA address or to the alternative address. If the network adapter is once again connected to the DHCP network, configuring to a DHCP address takes place right after the connection has been detected.

Addressing a network adapter via DHCP without alternative addressing is not supported.
5.4 User Interface

5.4.1 Configuration Dialog Window 1 — Selection of Network Adapter
("Network settings for ETAS hardware (page 1)"

The following information on the available network adapters is displayed:

- **Auto IP Address Range checkbox**
  
  If you tick this checkbox, the next configuration step is skipped, and the ETAS Network Manager automatically assigns default IP address ranges that will be used by the selected network adapter for addressing the ETAS hardware. If the IP address range is automatically changed by the IP Manager, a message is displayed in the system tray.

- **Auto Configure ETAS Network checkbox**
  
  If you tick this checkbox, you can enable or disable several network adapters at once for auto-configuration through the IP Manager. When you tick the checkbox, the "Auto IP Address Range" checkbox is activated. In the list of available network adapters, the "Active for ETAS Network" column is inserted, where you can determine which network adapters shall be available for auto-configuration through the ETAS Network Manager.

  The ETAS Network Manager will go through the list (top-down) and use the first adapter which has a valid IP configuration for ETAS and configure the IP address range automatically. If a configured network adapter fails, e.g. because the network adapter is being disabled or physically not available, the IP Manager will configure the next available network adapter automatically, and a message is displayed in the system tray, indicating the new configuration.

- **Active for ETAS Network column**
  
  This column is only visible if the "Auto Configure ETAS network" checkbox is ticked. In the checkbox in this column you can determine which network adapters shall be enabled for autoconfiguration by the ETAS Network Manager (siehe „Auto-Configuring Network Adapter for ETAS Hardware“ auf Seite 77).

---

1. An IP configuration is valid if the network adapter either uses a fix IP address, or if DHCP and APIPA are enabled.
• Name column
Name of the network adapter. This entry cannot be edited in this window.
This column also contains an entry with the name "No Adapter". If you want to disable the IP Manager, e.g. because there is no Ethernet hardware connected to the PC, you can tick this entry in the "Active for ETAS Network" column.

• IP Address column
IP address of the network adapter. This entry cannot be edited in this window.

• Subnet Mask column
Setting for the subnet mask. This entry cannot be edited in this window.

• DHCP column
Shows whether the network adapter is configured for DHCP:
- Enabled
  The network adapter is configured for DHCP.
- Disabled
  The network adapter is configured with a fixed IP address.

• Alternate IP Configuration column
Shows the alternative IP address of the network adapter if it is configured for DHCP. This indication depends on the operating system being used.
- APIPA
  Automatic Private IP Addressing: method for automating the IP configuration for network connections
- ... 
  An alternative IP address does not exist.
- User defined
  The user can define a user-specific alternative IP address.

5.4.2 Configuration Dialog Window 2 — Defining the Address Pool
("Network settings for ETAS hardware (page 2)")

In general, all values can be modified by directly typing them in the corresponding field, or by selecting the default setting from a list box.
The following network parameters can be set:

- **Start Address**
  The first IP address in the IP address range for the ETAS hardware
- **End Address**
  The last IP address in the IP address range for the ETAS hardware
- **Subnet Mask**
  Associated Subnet Mask

**Reserved IP Addresses**

The following IP addresses are reserved for certain ETAS hardware in the IP address range that the ETAS hardware (192.168.40.1 - 192.168.40.254 with Subnet Mask 255.255.255.0) is currently using:

<table>
<thead>
<tr>
<th>IP_Address</th>
<th>ETAS Hardware</th>
</tr>
</thead>
<tbody>
<tr>
<td>192.168.40.10</td>
<td>ES1120</td>
</tr>
<tr>
<td>192.168.40.11</td>
<td>ES1130</td>
</tr>
<tr>
<td>192.168.40.12</td>
<td>ES780</td>
</tr>
<tr>
<td>192.168.40.13</td>
<td>Reserved</td>
</tr>
<tr>
<td>192.168.40.14</td>
<td>ETAS Real-Time PC</td>
</tr>
<tr>
<td>192.168.40.15</td>
<td>ES1135</td>
</tr>
</tbody>
</table>

These addresses are assigned exclusively to these devices and thus may not be used for other ETAS hardware. This has to be taken into consideration when defining the address pool.

**5.4.3 Configuration Dialog Window 4 — Displaying Warning**

("Network settings for ETAS hardware (Page 4)"

This dialog window appears only if the selected network adapter is addressed manually.
The following parameters can be set:

• Display warning before IP address assignment is executed

Use this checkbox to specify that a warning be displayed before an IP address is assigned to an ETAS hardware device.

**NOTE**

Enabling this warning is useful only if you want to run the PC both in the company network or on an ETAS measurement module in the ETAS network using this network adapter.

### 5.5 Configuring Network Addresses for ETAS Hardware

#### 5.5.1 Manually configuring the Network Adapter

**To configure the network adapter for ETAS hardware:**

1. In the Windows Start menu, go into the program folder of your ETAS software (below Start → Programs → ETAS), and select ETAS Network Settings.

   The "Network settings for ETAS hardware (Page 1)" dialog window is opened.

2. In the "Available Network Adapters" area, select the network adapter you want to use for the corporate network and the ETAS network. If no network adapter is installed on the PC, the dialog window contains no entries.

**NOTE**

The type of addressing of the network adapter must be supported by the ETAS network. Otherwise, you cannot select the network adapter.
3. Click **Continue**.
The "Network settings for ETAS hardware (Page 2)" dialog window opens.

![Network settings dialog for ETAS hardware (Page 2)](image)

4. Enter the IP address range for the ETAS hardware and the subnet mask, or click **Default** to have the Network Manager automatically complete the IP address range and the subnet mask. You may accept these settings or overwrite them.

5. Click **Continue**.
The "Network settings for ETAS Hardware (Page 4)" dialog window opens.

![Network settings dialog for ETAS hardware (Page 4)](image)

6. If you want to define that a warning is displayed before the ETAS hardware is assigned an IP address, enable "Display warning before IP address assignment is executed".

![Warning message](image)

**NOTE**
Enabling this warning is useful only if you want to run the PC both in the company network or on an ETAS measurement module in the ETAS network using this network adapter.

7. Click **Finish**.
8. Restart the ETAS software to make the changes become effective. If the Network Manager was started automatically during a hardware search or initialization, you do not have to restart the ETAS software to apply the changes.

5.5.2 Auto-Configuring Network Adapter for ETAS Hardware

The ETAS Network Manager offers the automatic assignment of IP address ranges in the ETAS network through the IP Manager. You can either use auto-configuration of a selected network adapter, or, if more than one network adapter is available, let the IP Manager auto-configure the ETAS network, including the selection of the adapter to be used.

**How to auto-configure a selected network adapter for ETAS hardware**

1. In the Windows Start menu, go into the program folder of your ETAS software (below Start → Programs → ETAS), and select ETAS Network Settings.

   The 'Network settings for ETAS hardware (Page 1)' dialog window is opened.

2. In the "Available Network Adapters" area of the "Network settings for ETAS hardware (Page 1)" dialog window, select the network adapter you want to use for the corporate network and the ETAS network. If no network adapter is installed on the PC, the dialog window contains no entries.

   ![Image of network settings dialog window](image)

   - **NOTE**
     The type of addressing of the network adapter must be supported by the ETAS network. Otherwise, you cannot select the network adapter.

3. Tick the "Auto IP Address Range" checkbox.
4. Click **Finish**.

   The ETAS Network Manager automatically assigns default IP address ranges that will be used by the selected network adapter for addressing the ETAS hardware.
If later on, the IP address range is automatically changed by the IP Manager, a message is displayed in the system tray.

**How to auto-configure a network adapter, with multiple network adapters being available**

1. In the Windows Start menu, go into the program folder of your ETAS software (below Start → Programs → ETAS), and select ETAS Network Settings.

   The "Network settings for ETAS hardware (Page 1)" dialog window is opened.

2. In the "Network settings for ETAS hardware (Page 1)" dialog window, tick the "Auto Configure ETAS Network" checkbox.

   The "Auto IP Address Range" checkbox is activated, and in the list of available network adapters, the "Active for ETAS Network" column is inserted.

3. Enable all network adapters that shall be available for auto-configuration through the IP Manager by ticking the corresponding checkbox in the "Active for ETAS Network" column.

4. Click Finish.

Starting with the network adapter that is currently selected in the dialog window, the ETAS Network Manager will go through the list (top-down), and use the first adapter which has a valid\(^1\) IP configuration for ETAS and configure the IP address range automatically. If a configured network adapter fails, e.g. because the network adapter is being disabled or physically not available, the IP Manager will configure the next available network adapter automatically, and a message is displayed in the system tray, indicating the new configuration.

---

\(^1\) An IP configuration is valid if the network adapter either uses a fix IP address, or if DHCP and APIPA are enabled.
5.5.3 Enabling APIPA in the Registry

**NOTE**

You need administrator rights to make changes in the Registry.

To enable APIPA in the Registry:

1. Click **Start**, and then click **Run**.
2. Enter `regedit`, and click **OK**.
   
The Registry editor opens.
3. Click the entry for a network adapter in the Registry key:
   - Global key (refers to all network adapters)
     
     \[\text{HKEY\_LOCAL\_MACHINE}\backslash \text{SYSTEM}\backslash \text{CurrentControlSet}\backslash \text{Services\Tcpip\Parameters}\]
   - Interface or card-specific key
     
     \[\text{HKEY\_LOCAL\_MACHINE}\backslash \text{SYSTEM}\backslash \text{CurrentControlSet}\backslash \text{Services\Tcpip\Parameters}\backslash \text{Interfaces}\backslash \text{adapter\_name}\]
4. Set the value for `IPAutoconfigurationEnabled` to 1.
   
The APIPA mechanism is enabled.

**NOTE**

If neither of these keys exists, the APIPA mechanism is enabled. If the global key exists but is not enabled, the setting of the global key is decisive. If the global key does not exist or is set to enabled, the card-specific key is decisive.
6 Contact Information

ETAS Headquarters
ETAS GmbH
Borsigstraße 24 Phone: +49 711 3423-0
70469 Stuttgart Fax: +49 711 3423-2106
Germany Internet: www.etas.com

ETAS Subsidiaries and Technical Support
For details of your local sales office as well as your local technical support team and product hotlines, take a look at the ETAS website:

ETAS subsidiaries Internet: www.etas.com/en/contact.php
ETAS technical support Internet: www.etas.com/en/hotlines.php
## Index

**C**
- Code generating ..................................... 41, 58
- Connection Manager .................................. 54

**D**
- Data Protection Declaration ......................... 7

**E**
- ETAS EE ............................................. 12
- ETAS Experiment Environment ....................... 12
- ETAS Network
  - Addressing ......................................... 70
  - Configure network adapter ......................... 75
  - DHCP ............................................... 71
  - Network Manager .................................. 72
  - Reserved addresses ................................ 74

**G**
- GUI creating ........................................ 43

**H**
- Hardware configuring ................................ 49
- Hardware configuration creating .................... 49

**I**
- IdleController
  - model .............................................. 36
- INCA version selecting ................................ 29
- Import
  - adding ............................................... 52
- Installation .......................................... 22
  - preparation ......................................... 22
  - system requirements ............................... 22
  - user privileges .................................. 23

**L**
- LABCAR Inport ...................................... 52
- LABCAR license models ................................ 31
- LABCAR Outport ..................................... 52
- LABCAR-CCI ......................................... 14
- LABCAR-LCE ......................................... 15
- LABCAR-LCX ......................................... 15
- LABCAR-MCA ......................................... 14
- LABCAR-MCS ......................................... 14
- LABCAR-NIC ......................................... 15
- LABCAR-NIF ......................................... 15
- LABCAR-NIL ......................................... 15
- LABCAR-OPERATOR
  - creating a project ................................ 38
  - launching .......................................... 37
- LABCAR-OPERATOR version selecting .............. 28

- LABCAR-RTC V5.1 .................................. 14
- Language versions
  - operating system .................................. 23
- License
  - license models .................................... 31

**M**
- Manuals .............................................. 8
- MATLAB version selecting ......................... 28

**O**
- Operating systems .................................. 23
- OS Configurator
  - launching .......................................... 57
- Oscilloscope creating ................................ 43

**R**
- Real-time operating system configuration ........ 57

**S**
- Scope of delivery .................................. 22

**T**
- Tutorial ............................................. 35